PreRequisites/fr

From phpLDAPadmin

Jump to: navigation, search


Pré requis :

phpLDAPadmin nécessite :

   * Un serveur LDAP en état de marche accéssible de votre poste de travail. (PLA a été testé et fonctionne avec les serveurs suivants : Serveurs LDAP?.)
   * Un serveur WEB (Apache, IIS,...)
   * PHP4.1.0 ou plus installé avec
         o Support LDAP
         o Support XML


PLA est développé sous Fedora Core 3 (Apache 2, PHP 4, OpenLDAP 2.2). Il devrait parfaitement fonctionner avec d'autres versions de ces logiciels.

NOTA BENE: PLA peut ne pas bien fonctionner sous PHP 5. Il n'a pas été testé totalement. Si il fonctionne ou si vous savez comment faire pour qu'il fonctionne, n'hésitez pas à nous contacter.

Installation :

1. Dé-tarer l'archive (si vous lisez ceci, c'est que vous l'avez déjà fait). 2. Mettre le répertoire 'phpldapadmin' ainsi obtenu quelque part sous la racine de votre serveur web. 3. Copier 'config.php.example' vers 'config.php' et editer selon vos besoins. 4. Ensuite, pointer votre navigateur vers le répertoire phpldapadmin.

Aide suplémentaire

   * Voir les fichiers inclus dans le répertoire 'doc' de la distribution.
   * Inscrivez vous sur notre liste de diffusion


Spécification pour certaines plateformes : OpenBSD avec serveur Apache "chrooté" : Pour que les photo jpeg soient traitées correctement vous devez exécuter les commandes suivantes :

   * mkdir /var/www/tmp
   * chown root:daemon /var/www/tmp
   * chmod 1755 /var/www/tmp


Mettre à jour $config->custom->tmpdir['jpeg'] à /var/www/tmp dans config.php.


Windows Pour utiliser correctement les photos jpeg, n'oubliez pas de changer la valeur $config->custom->tmpdir['jpeg'] de /tmp en c:\\temp ou similaire (notez bien le double antislash \\)



Personal tools